Back to overview
Degraded

Issue with submissions search on tenancies

Jun 30 at 09:13am IST
Affected services
EQUAL

Resolved
Jun 30 at 09:19am IST

We have identified the issue with the submissions search and deployed a fix

Created
Jun 30 at 09:13am IST

Engineering are investigating reports of the submissions search not loading