EQUAL Release 119.1.0
Resolved
Feb 16 at 11:16am GMT
Deployment has been completed successfully.
Affected services
Updated
Feb 16 at 11:12am GMT
Engineering are now smoke testing deployment.
Affected services
Updated
Feb 16 at 11:07am GMT
The Engineer team has begun the release
Affected services
Created
Feb 16 at 10:30am GMT
The EQUAL Dev team are continuing trialling multiple releases throughout our fortnightly sprint cycle. There is no anticipated downtime for any of these. Below is a summary of the work released
If you've got any questions about the items in the release, please feel free to ask. Please feel free to share with any customers so they're aware of the upcoming changes.
New Features
Record sales of EQUAL Assess Credits
We've added the ability to record EQUAL Assess credit transactions in the sales credit management system. This is available through a new Product type for EQUAL Assess credits.
Internal Bug Fixes
Fix Course Certificate storage
There was an issue flagged during testing of a recent update to the certificate generation process that was unlikely to affect any end users but we wanted to get sorted quickly. You should not notice any changes.
Handle deleting orphaned records from the EQUAL database
We recently moved our handling of file storage to Azure blobs. This release adds a script that will allow us to clean up part of the EQUAL database where we had stored data. You should not notice any changes
Race condition causes duplicate feedback submissions in EQUAL Assess
There was an issue found where if you submitted answers on different tabs or tried to submit the same feedback in quick succession it could hit the EQUAL Assess endpoint and cause noisy log errors. It also had the ability to affect feedback generation. We've implemented a couple of catch all's to this process that should stop this from happening.
Affected services